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1 Introduction 
 

This document is intended to assist providers with the acquisition and use of security certificates when accessing 
secured eMedNY Web Services (such as the File Transfer Service and the Meds History Service.) It details the processes 
needed to create a private and public key pair, and an associated Certificate Signing Request (CSR) and how to process 
the resulting signed certificate delivered in response from eMedNY, as well as how to import any server certificates that 
may also be required (e.g MedsHistory Web Service). 

 

The process to enroll as a user of eMedNY-signed certificates , to submit the Certificate Signing Request created as 
described in this document, and the retrieval of the user’s eMedNY-signed certificate are detailed in a separate 
document  eMedNY X509 Certificates Guide. 

 

Please note that the information provided is to be used as a guide only. It will be of greatest interest to developers using 
Java or Dotnet technologies on Windows platforms. Developers on Linux-variants should be able to adapt the 
instructions given herein. Developers using key and certificate stores other than those covered in this document will 
have to adapt the information here to the fit their own situation. 

https://www.emedny.org/selfhelp/SOAP/eMedNY_File_Transfer_Service_User_Guide_1.0.pdf
httpshttps://www.emedny.org/selfhelp/SOAP/eMedNY_Meds_History_Service_User_Guide_1.1.pdf
https://www.emedny.org/selfhelp/SOAP/eMedNY_X509_Certificate_Request_User_Guide_1.0.pdf
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2 Creating a Certificate Signing Request (CSR) and 
requesting a Certificate 

“Keytool” is a key and certificate management utility, which will be used to generate key pairs for your web services 
client. This utility will need to be installed so that it can be run in any directory. For additional information regarding 
keytool, see keytool web link in Section 4.1. The following instructions are for Windows-based operating systems. 
Other operating systems have analogous tools; users should consult the appropriate references or with your IT 
departments. 

eMedNY can provide scripts contained in batch files with these commands. They can be run using instructions 
contained within these files. Please email emednyproviderservices@gdit.com to request these scripts. 

 

The following instructions are for example purposes only. Words that are in bold are sample text, please use whatever 
suits the needs of your software in its place. 

 

2.1 Create the “KeyStores” Folder & Open the Command 
Window 

In Windows Explorer you will need to create a new folder for your keytool-related files. In our example, we have called 
it KeyStores: 

 

mailto:emednyproviderservices@gdit.com
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Next, In Start Menu Click Run: 

 
Type “cmd” and press Enter: 

 
 
 

Change directory to the one you created earlier (i.e. Keystores): 
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2.2 Generate a key pair for your web service client 
At the command line, type in the following command, substituting your own data for the text in brackets []. A full 
explanation of this data appears after the command line: 

keytool -genkeypair -v -alias [Client Alias] -keystore [keystore name].jks -keyalg RSA -sigalg SHA1withRSA -storepass 
[keystore password] -dname “[Client’s DN, see below]” -keypass [client password] 

Client Alias – An alias set up by the user. It is used to refer to the keystore. A keystore can contain multiple client items, 
each referenced by its own unique alias. 

Keystore Name – The name of the Keystore. A file named [keystore name].jks will be generated. 
 

Keystore Password – A password to access the keystore. We suggest a password should be at least six characters in 
length and contain at least one number and punctuation mark. 

 
Client’s DN – This is information identifying the client. You should populate it with information identifying your 
organization (using no spaces) as follows: “CN = [Client Name], OU=[Organizational Unit], O=[Organization], L=[City or 
Locality], S=[State], C=US” 

Client Password – The client password to access the private key in this keystore. 

This is an example: 

keytool -genkeypair -v -alias JDOE -keystore JDOEKeystores.jks -keyalg RSA -sigalg SHA1withRSA -storepass Password1 - 
dname “CN=JohnDoe,OU=IT,O=JohnDoeInc,L=Anytown,ST=NY,C=US” -keypass Password2 

 

See below for an example: 
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2.3 Generate a certificate request 
Type the following command to generate a Certificate Signing Request. Replace the text in brackets with the same data 
you used to generate the Keystore. 

keytool -certreq -alias [Client Alias] -keystore [Keystore Name].jks -file [Client Alias].csr -storepass [Keystore Password] - 
keypass [Client Password] 

 

See below for an example: 
 

keytool -certreq -alias JDOE -keystore JDOEKeystores.jks -file JDOE.csr -storepass Password1 -keypass Password2 
 

The image follows that example: 
 

 
This will result in a Certificate Request file (.csr) being placed into the same directory. 

 

2.4 Submit the Certificate Signing Request through ePACES 
View the Keystores directory in Windows explorer. 

 
 

 
As you can see above, there are two files in the directory. The .jks is your keystore file. The .csr is your Certificate 
Signing Request. Open the .csr file in a text editor, such as NotePad. It should look something like this: 
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Copy this information into the “Certificate Signing Request” Field in ePACES as per the instructions in the eMedNY X509 
Certificates Guide. 

 

2.5 Retrieve the Client Certificate from ePACES 
Retrieve the Client Certificate through ePACES as per the instructions in the eMedNY X509 Certificates Guide. Copy the 
data there into Notepad and save it in the “Keystores” directory under the name [Client Alias].pem 

https://www.emedny.org/selfhelp/SOAP/eMedNY_X509_Certificate_Request_User_Guide_1.0.pdf
https://www.emedny.org/selfhelp/SOAP/eMedNY_X509_Certificate_Request_User_Guide_1.0.pdf
https://www.emedny.org/selfhelp/SOAP/eMedNY_X509_Certificate_Request_User_Guide_1.0.pdf
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This is a sample of a Client certificate. 
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3 Importing the Certificate 
 
3.1 Importing the Client Certificate into the keystore 
Type the following command to import the Client Certificate into your keystore. Replace the text in brackets with the 
appropriate data – [Cert file name] is the name of the file where you saved the certificate from ePACES. An explanation 
of the data elements follows the command: 

 
keytool -importcert -v -alias [Client Alias] -file [Cert file Name].pem -keystore [Keystore name].jks -storepass [keystore 
password] -keypass [client password] 

Client Alias – The same Client Alias as above. 
 

Cert File Name – the Name of the desired certificate file. We recommend the same as the Client Alias for tracking 
purposes. 

Keystore Password – A password to access the keystore. We suggest a password should be at least six characters in 
length and contain at least one number and punctuation mark. This is the same as used for creating the keystore and 
generating the CSR. 

 

Client Password – The client password to access the private key in this keystore. 

This is an example command: 

keytool -importcert -v -alias JDOE -file JDOE.pem -keystore JDOEKeystores.jks -storepass Password1 -keypass 
Password2 

 
The following image follows our example: 
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The reason the certificate is indicated as “not trusted” as the certificate returned by eMedNY is a chain consisting of the 
user’s cert as well as the Certificate Administrator Signer Cert (rPrd Certificate Authority.) It is the latter certificate that 
is “not trusted.” You can also import only the eMedNY client cert without the CA signer cert if you first import the 
returned chain into Internet Explorer and then re-export just the eMedNY client cert from the browser. If you need to 
do this for your software, see the instructions under Importing Certificates using the IE Certificates Wizard. 

 

3.2 Importing the Server Certificate 
For Java based web service clients, doing message level security (e.g. Meds History Service - MHS,) the Server certificate 
needs to be imported into this keystore or in a separate keystore. We will do it in this keystore. 

 
The Server certificate can be obtained from eMedNY – please email emednyproviderservices@gdit.com if you need this 
certificate. For this demo, it will be downloaded to: 

mailto:emednyproviderservices@gdit.com
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C:\Keystores\dev_server.pem 

 
And imported using KeyToolIUI via Import > Keystore’s entry > Trusted Certificate > Regular Certificate 

 
However, this will fail. This is because the eMedNY cert contains a certificate chain (server cert + CA cert) and a jks 
keystore will not allow one to import a cert as a trusted cert if it contains a chain. We will need the server certificate 
without a chain (i.e remove the CA cert.) Note we could import the client cert jsmith.cer because the keystore contains 
its private key and we imported into an existing entry and replaced the self-signed cert in it with the jsmith cert + CA 
cert. However as we do not have the server’s private key we cannot do the same. (Other alternatives are also possible 
such as creating a pkcs12 keystore, or obtain the signer certficate and importing it as a trusted cert. However the 
process given in this document will be applicable to both Java and Dotnet developers on Windows platforms. ) 

 
The way around this is to first import the eMedNY Server certificates (servercert + cacert) into the Windows Certificate 
Store. Then export only the servercert from the Windows Certificate Store and then import the servercert into the 
keystore as a trusted cert. 

There are two ways of doing this, the first giving a more detailed view into the Windows Certificate Store, while the 
second is less granular but simpler to use. 

 

• Using a Microsoft Mangement Console (mmc) for the Windows Certificate Stores 
• Using the Internet Explorer Certificates Wizard. 

3.3 Importing certificates using a MMC. 
First create a Microsoft Management Console (mmc) for the Certificate Store by doing the following: 

 
3.3.1 From the Windows task bar, Start > Run > mmc 

 

 
3.3.2 File > Add/Remove Snap-in 
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3.3.3 Click “Add…” 
 

 
3.3.4 In the “Add Standalone Snap-in”, select “Certificates” and Click “Add” 
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3.3.5 Select “Computer account”, then click “Next” 
 

 
3.3.6 Select “Local computer (the computer this console is running on)”, and click Finish 
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3.3.7 Note that the “Certificates (Local Computer)” has been added to the “Add/Remove Snap-in” 
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Close the “Add Standalone Snap in”. 

 
3.3.8 In the “Add/Remove Snap-in” click on the “Add..” again and repeat steps 3.3.4 and 3.3.5, but this time for step 
3.3.5 select the “My user account”. 

 

 
Then Close the “Add Standalone Snap-in” 



K E Y TO  O L A N D C E R T I  F IC  A T E M A N A  G E  M E NT  

eMedNY Subsystem User Manual 
Version 1.1 

Page 17 of 35 February 16, 2013 

 

 

 
 

 
 

Note that “Certificates – Current User” has also been added to the “Add/Remove Snap-in” 

Click on the OK button 

3.3.8 Save the mmc console 
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For example, in the Keystores folder as “MyWindowsCertStore” 
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3.4 Importing Certifcates Using the IE Certificates Wizard 
Open Internet Explorer go to the Tools > Internet Options menu 

 

 
Go to the Contents tab and click on the Certificates button 
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Click on Import… 
 

 
Click the Next button 

 
Navigate to the dev_server.pem file which you downloaded from eMedNY 
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Click Next 
 

Notice it says Personal store. Click on Browse, select the “Other People” store. (Note: you can also put it in the 
"Personal" store, but as it is a server certificate, it might be more appropriate to put it in the "Other People" store and 
leave the "Personal" store for your own certificates. Also note that these are put into what is known as the "Certificates 
– Current User" stores. There is also a "Certificates (Local Computer)" stores which can also be used.) 

 
And click OK 
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Click Next 
 

 
Click Finish. Note the import was successful and click OK. 

 
Click on “Other People” tab. The DPMedsHistory (which is the name of servercert) issued by “rPrd Certificate 
Authority” (the eMedNY CA) is now in the Windows Certificate Store. Note also that the CA cert in the chain, rPrd 
Certificate Authority is also imported. Click on the DPMedsHistory entry to select it. The Export button is now enabled. 
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Click on the Export… button, and then Next 
 

 
And select the base-64 encoded X.509 radio button, 
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Click Next 
 

Navigate to the folder you created for your keystores (in our example “Kestores”) folder and give the exported file a 
name (for example “server” here) with extension “.cer” and Save it. 
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Click Next 
 

 
Note that the Keys (i.e private keys if any) are not exported and that all certificates in the certifcation path are not 
included (i.e. the CA cert is not included,) which is what we wanted from this digression using the Windows Certificate 
Store tool. 

Click Finish and note that the export was successful 
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Click OK 
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Click Close and then OK. 

 
So now we have the “server.cer” exported into the KeyToolDemo folder 

 

3.5 Importing the Server Certificate into the Keystore 
We can now proceed to import the server certificate into the keystore. 

 
Open the command prompt and navigate to the folder you created for your Keystore. In our example, we named it 
“Keystores.” 

 
Type the following command line: 

 
keytool -importcert -v -alias [Server Cert Alias] -file [Cert file Name].pem -keystore [Keystore name].jks -storepass 
[keystore password] -keypass [client password] 

 

The following is a sample command: 
 

keytool -importcert -v -alias Server -file Server.cer -keystore JDOEKeystores.jks -storepass Password1 -keypass 
Password2 

 
This image follows the sample: 
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3.6 Importing private key and certificates from Java to 
Windows Key Stores 

If you have a Dotnet application, you will not be able to use the java JDOEKeystores.jks so you will have to export the 
private key and cert of JDOE into the Windows Certificate Store. You have already imported the server certificate into 
that store. 

The procedure for doing the JDOE.pem is similar. 
 

Open your IE browser, From the menu, go to Tools > Internet options > Content tab and click on Certificates button. 
 



K E Y TO  O L A N D C E R T I  F IC  A T E M A N A  G E  M E NT  

eMedNY Subsystem User Manual 
Version 1.1 

Page 30 of 35 February 16, 2013 

 

 

 
 

 
 

Click Import… , Next and select your JDOE.pem file that was returned with your csr request. 
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Click Next 
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And place the certifcate in the “Personal” store. Click Next 

 

 
And Finish 
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You will need to create a mmc certificates to view cert for JDOE imported into CurrentUser/Personal/Certificates. The 
Windows Cert Store only shows CurrentComputer stores. 
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4 Additional Tools and Information 
 
4.1 keytool web link 

http://java.sun.com/j2se/1.3/docs/tooldocs/win32/keytool.html 
 

4.2 Requirements for CORE Compliance 
http://www.caqh.org/benefits.php 

 

4.3 JSSE Reference Guide 
http://docs.oracle.com/javase/6/docs/technotes/guides/security/jsse/JSSERefGuide.html#SSLOverview 

 

4.4 WCF – 2 Way SSL using Certificates 
http://blogs.msdn.com/b/imayak/archive/2008/09/12/wcf-2-way-ssl-security-using-certificates.aspx 

 

eMedNY neither endorses nor recommends any of the tools linked or referenced in this document. The intent here is 
strictly informational. 

http://java.sun.com/j2se/1.3/docs/tooldocs/win32/keytool.html
http://www.caqh.org/benefits.php
http://docs.oracle.com/javase/6/docs/technotes/guides/security/jsse/JSSERefGuide.html#SSLOverview
http://blogs.msdn.com/b/imayak/archive/2008/09/12/wcf-2-way-ssl-security-using-certificates.aspx
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eMedNY is the name of the electronic New York State Medicaid system. The eMedNY system allows 

New York Medicaid providers to submit claims and receive payments for Medicaid-covered 
services provided to eligible clients. 

eMedNY offers several innovative technical and architectural features, facilitating the 
adjudication and payment of claims and providing extensive support and convenience for its 

users. 

The information contained within this document was created in concert by eMedNY and DOH. 
More information about eMedNY can be found at www.emedny.org. 

http://www.emedny.org/
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